• Posted: 2020-08-24
  • المؤلف: zzz
  • تاريخ الإضافة release

0.9.47 enables our new end-to-end encryption protocol (proposal 144) by default for some services. The Sybil analysis and blocking tool is now enabled by default.

Java 8 or higher is now required. Debian packages for Wheezy and Stretch, and for Ubuntu Trusty and Precise, are no longer supported. Users on those platforms should upgrade so you may continue to receive I2P updates.

As usual, we recommend that you update to this release. The best way to maintain security and help the network is to run the latest release.

RELEASE DETAILS

Changes

  • Java 8 now required
  • Jetty 9.3.28
  • Tomcat 9.0.35
  • Json-simple 2.3.0
  • RRD4J 3.6
  • ECIES-X25519-AEAD-Ratchet encryption enabled for i2psnark, shared clients, HTTP proxy, and new tunnels
  • Increase streaming MTU for ECIES connections
  • Enable Sybil analysis and blocking tool by default

Bug Fixes

  • Hidden Services Manager: Fix missing server tunnel length configuration
  • Hidden Services Manager: Fix missing server throttle configuration
  • i2psnark: Fix javascript confirmation for delete buttons
  • UPnP: More fixes for changing interfaces and devices
  • Fix DoH handling of Cloudflare responses
  • Fix blinded/encrypted leaseset creation
  • Fix persistent leaseset keys

Other

  • Sign Windows dlls
  • Faster gzip uncompression for level 0
  • i2psnark: Increase max pipeline
  • Translation updates

Full list of fixed bugs

SHA256 Checksums:

351fa15544133a7991cd0b17722286b37255c074591c16f79d3af426ee10f2be  i2pinstall_0.9.47_windows.exe
3ddf3afb0c06edeed4810c6d1f34d909959dd94640adf7c638781b4a3b282e9e  i2pinstall_0.9.47.jar
dbccada6a353b54ceb844fe8cb0912c0363375a2f57214d23fcf463c4e6d2c4f  i2psource_0.9.47.tar.bz2
328f85ba28ff6f60480aa0dcda88654fabeabcf63b732a770354bff7f134b135  i2pupdate_0.9.47.zip
29fcf906bdb4e94dba55ef5bda491b074ef279502290e3df7783925dec159983  i2pupdate.su3

Flattr this